x64 version doesn't work

  • Problem
  • Updated 2 years ago
  • Solved
So whenever I try to run a benchmark I get this error popup:

3DMark11Demo.exe - Application Error
The application was unable to start correctly (0xc000007b). Click OK to close the application.

Followed by:

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: 3dmark11.exe
Problem Signature 02: 1.0.2.0
Problem Signature 03: 4ddba0b5
Problem Signature 04: PresentationFramework
Problem Signature 05: 4.0.0.0
Problem Signature 06: 4d930fa2
Problem Signature 07: 80cf
Problem Signature 08: 0
Problem Signature 09: System.NullReferenceException
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 8a91
Additional Information 2: 8a91fdd38eb56c944fbfc44ab0551792
Additional Information 3: 342a
Additional Information 4: 342a04ebd4e256ec8ff5484612416eac

Weirdest thing is the 32bit version of the program runs fine.

I've tried reinstalling the program, reinstalling .net framework and the c++ download from microsoft. Windows is completely up to date.

I'm totally lost as I've been trying to solve this for the last 4 1/2 hours.

What is the problem here?

faisalkhan729

  • 2 Posts
  • 0 Likes

Posted 2 years ago

  • 2

FM_Jarnis, Official Rep

  • 6244 Posts
  • 400 Likes
The error message points towards a problem with the .net framework, so that would be where I would start - however, if you have already tried reinstalling .net framework 4, I'm not sure what else could be done.

I've forwarded the error to our lead programmer in case he has any ideas. I'll let you know when I hear back from him.

FM_Jarnis, Official Rep

  • 6244 Posts
  • 400 Likes
Okay, I checked with the lead programmer and he didn't have any clear idea why this would happen, but one thing was cleared up; The demo executable is crashing first, followed by the UI (which uses net framework), so that actually rules out net framework issues. The net framework message is a secondary effect of the crash.

Does the crash occur if you choose to run the benchmark tests only (no demo)? If benchmark tests work but demo doesn't, it could point towards an issue with audio drivers as the main difference between the two would be the fact that demo has sound.

faisalkhan729

  • 2 Posts
  • 0 Likes
It doesn't work on either but just to troubleshoot, I decided to install windows 7 on my second hdd.

Lo and behold after only updating directx and installing all windows updates, 3dMark 11 works perfectly.

So I backed up my important stuff and did a reinstall on my SSD. Gonna thread cautiously with my setup as I have my users folder on another hdd.

Must have been something conflicting with my previous setup.

FM_Jarnis, Official Rep

  • 6244 Posts
  • 400 Likes
Well, glad you figured out a solution even if the root cause is still bit of a mystery.

In any case it really had to be something specific to your configuration, considering how much testing 3DMark and PCMark receive before launch. In addition to extensive in-house testing, they go through the test labs at our BDP partners - Intel, AMD, Nvidia etc - so any "common" bug would probably stand out...